Go Back   Motorcycle Forum > Motorcycle.Com General Discussion > Motorcycle Mods and Maintenance

Reply
 
Thread Tools
Old 09-15-2011, 09:37 AM   #1
al_toro
Registered Member
 
Join Date: Sep 2011
Posts: 2
Default No CLUTCH... HELP!!

OK so i was diving back from florida to nj on my 95 katana 600 and my chain snapped and went into the front cranckcase cover and did some damage. .
It twisted up a plate,lost a clutch spring, and broke another piece i cant quite figure out.
I put it back together with new parts like the plate, engine dampers, clutch spring and chain but something is still missing bc i have no clutch still
It starts but doesnt shift into any gears
what could be the problem?
Any help will be greatly appreciated since im doing it all myself
al_toro is offline   Reply With Quote

Sponsored Links Remove Advertisements
Motorcycle Forum
Advertisement
Old 09-15-2011, 10:26 AM   #2
The Spaceman
Registered Member
 
The Spaceman's Avatar
 
Join Date: Aug 2011
Posts: 2,448
Default

The clutch probably needs adjustment. If you're lucky, it will just be the cable. If not, or if its hydraulic, you'll need to pull the cover. There is a specific process for each bike on how to set it correctly; I'd google that and see if you can find a step by step.
__________________
318 curves in 11 miles."
The Spaceman is offline   Reply With Quote
Old 09-15-2011, 11:22 AM   #3
Easy Rider 2
Registered Member
 
Join Date: Dec 2010
Location: North Central Florida
Posts: 844
Default

Quote:
Originally Posted by al_toro View Post
since im doing it all myself
As things turned out, that might be a mistake.

You NEED someone with more experience (a bike mechanic) to be there and SEE what the situation is.

Did you operate the clutch while you had the side cover off to see what, if anything, was happening inside ??
__________________
'11 Kawasaki Vulcan 900 C
Easy Rider 2 is offline   Reply With Quote
Old 09-16-2011, 01:06 PM   #4
al_toro
Registered Member
 
Join Date: Sep 2011
Posts: 2
Default

i didnt put any plastics back on just the cover to see if it would shift but there is like a little shaft the broke off and goes into the crankcase so i have to take the whole tranny out to replace whatever shaft is used to engage the clutch..
And i do have a help or a little guidance im just doing the work myself
i took it for a ride by popping the clutch but i cant shift and when i pull the lever in it does nothing
al_toro is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off