Motorcycle Forum

Motorcycle Forum (http://www.motorcycle.com/forum/)
-   Harley Davidson (http://www.motorcycle.com/forum/harley-davidson/)
-   -   2001 recal on Electra glide (http://www.motorcycle.com/forum/harley-davidson/10048-2001-recal-electra-glide.html)

jneezy 11-22-2008 08:50 AM

2001 recal on Electra glide
 
Hey I'm new to this site so please forgive my green pea questions.. I bought a 2001 Electra Glide from a HD shop forman last March 2008 with the Screamin Eagle stage 3 upgrade. The next week the bike just died, no lights, radio engine or anything then a few second later lights came on, I started the bike and I was off again. It happend again a few minutes later in stop and go traffic. I called around and a guy told me the 2001 had a circuit breaker recall. I took it in and the upgraded the breaker. It still did it when the engine oil temp got to 230 degrees. I took back to the dealer they said maybe a bad circuit breaker again, so they replaced it again. Now it does it at just over 205 engine oil temp. I'm frustrated and don't want to sell it becuase I love everything else about it. The one thing I changed before this ever happend was I put the HD show center stand on. I thought this might have had something to do with it so I unbolted it and put new washers and ground down the mounting bracket to ensure a good ground connection. Any helpful ideas would be much appreciated..

trenttheuncatchable 11-22-2008 09:48 AM

Does it happen if you turn the bike on and just let it idle for a while, or do you have to be riding it for it to happen? Have the shop actually figure out the problem. Instead of replacing a part and giving it back to you without seeing if they actually fixed it, they should make sure it's fixed before you get it back. After they fix it, tell them you're going to take it for a test ride and that you'll bring it back in an hour if it happens again. You might also consider taking it to a different shop (maybe an independent mechanic) who's interested in actually fixing your bike instead of focusing only on charging you and getting your bike out of the shop to make room for another.

longride 11-22-2008 10:09 AM

I have a 2001 Glide and never did the 'upgrade'. Something is tripping the main breaker, and it may be a short in the system or a connection getting hot and tripping it. Those intermittent things are tough to trace. Try disconnecting different circuits and that may point to the culprit.

jneezy 11-23-2008 04:00 PM

That sounds like good advice. Going back Monday or Tuesday I'll post any new results good or bad..Thanks for your help

jneezy 11-23-2008 04:13 PM

Which one should I try to disconnect first? It only does after its been running for at least 40 minutes and only at stop and go traffice..Thanks for your help

Buzglyd 11-23-2008 05:03 PM

Might be this
 
I've got an '03 Glide. My main circuit breaker kept tripping when it got hot (trust me, in bumper to bumper on the 405 this is not good!).

I did the recall and it kept tripping. The dealer was no help. I called Milwaukee directly and the guy on the phone was very helpful (amazing that I actually got help calling H-D directly. Try that with anyone else). He called the local dealer directly and explained the problem.

Apparently the connectors to the main circuit breaker can get a buildup on them. I'm no electrician, but this creates a heat problem that even caused the new circuit breaker to trip.

The dealer replaced the main circuit breaker and the connectors to it. I haven't had a problem since.

There ya go. Fixed. No charge.

Kenneth_Moore 11-23-2008 05:40 PM

"2001 Electra Glide from a HD shop forman last March 2008 with the Screamin Eagle stage 3 upgrade"

7 action-packed years of boring, stroking, cams, carbs, rods, pistons, cranks, heads, pipes...all done by the Alpha Dog wrench at the local HD shop.

Is it too late to get the extended warranty?


All times are GMT -7. The time now is 08:25 AM.